Houston / Cockpit setup on arm64?

I’m attempting to set up Houston on an arm64 server, running Rocky Linux 9.

I got through the install instructions for Rocky Linux 8, and with the exception of the packages cockpit-benchmark, cockpit-zfs-manager, and cockpit-45drives-hardware, I could install everything else, and Cockpit came up correctly.

I was wondering, as I looked into the 45Drives repository installation guide, if there are plans to support arm64 in addition to x86_64—I noticed there is only el7 and el8 right now, and only x86_64Index of /rhel/el8/stable/


If I try adding the repo I get:

Depsolve Error occurred: 
 Problem 1: cannot install the best candidate for the job
  - nothing provides zfs needed by cockpit-zfs-manager-1.3.1-1.el8.noarch from 45drives
  - nothing provides znapzend needed by cockpit-zfs-manager-1.3.1-1.el8.noarch from 45drives
 Problem 2: cannot install the best candidate for the job
  - nothing provides 45drives-tools >= 3.0.1 needed by cockpit-45drives-hardware-2.3.5-2.el8.noarch from 45drives

I’ve tried installing ZFS following the Manually installing ZFS for Rocky instructions, and I ran into:

ZFS on Linux for EL9 - dkms                                                        742  B/s | 369  B     00:00    
Errors during downloading metadata for repository 'zfs':
  - Status code: 404 for http://download.zfsonlinux.org/epel/9/aarch64/repodata/repomd.xml (IP:
Error: Failed to download metadata for repo 'zfs': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

It loks like the zfsonlinux project might not support aarch64 directly? Looking into that next.

Ah, looks like it’s not packaged officially for aarch64:

I think I may switch to Ubuntu instead of Rocky Linux, just for ease of maintenance (Ubuntu includes ZFS in the main packages)… however I noticed most of the docs from 45Drives deal with Ubuntu 20.04, whereas 24.04 is coming out quite soon, and 20.04 only has a year left on standard support…


Drat. Looking up the 45Drives repo, it looks like over in Ubuntu, the repo only supports amd64 as well: https://repo.45drives.com/lists/45drives.sources

I think I’ll go the route of manually setting up ZFS and a RAIDZ2 array, then managing it all via Ansible + custom…

Has anyone tried running cockpit-zfs-manager on arm64 before?


I can bust out a Pi and try manually. But that’s about all the help I can offer as my ARM game isn’t quite as strong as yours, with the most powerful ARM thing in the house being an M1 MBP 14".

The Ansible portion however is something I’ve been looking forward to from you. I’ve tossed around the idea of an Ansible driven NAS, as well as looking at NixOS.

IIRC, the cockpit-zfs-manager package is now helmed by the 45Drives team, and the original project has archived since. So, sad to say that you may hit the same roadblocks there.

I like Rocky, I actually grew to like dnf as well. However, I just feel much more at home with an apt and Debian based system. May want to poke at ryanmandle05’s work on Ubuntu 22.04.


Yes on arch based Manjaro arm linux. :wink:

[Not allowed for new user]

ZFS Image
[Not allowed for new user]

[Not allowed for new user]

Docker Image
[Not allowed for new user]

Aur have these plugin packages also there is a docker plugin where I maintain the aur pkg.

Looking at your issues with 45drives repo for arm64 they might have to test on arm boards more :wink:

Yes had to do the same :frowning:

1 Like