Prebuilt hl15 with TrueNAS Scale ipmitool issue

I’m trying to control the fans with ipmitool on my new HL15. I have installed TrueNAS Scale and when I try to run the tool I get:
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory
The ipmi web interface works just fine. What could the issue be?

The prebuilt system has the fans are connected to a component that the 45drives team made. That specific PCB is connected directly to the power supply.

here is a pictured of the module that was posted on a past thread.

The fans are not connected to motherboard.

here is some suggestion by one of members of this forum with a possible suggestion:

I was aware of this and should have added it to the original post.
I have found the issue. In order for the IPMI to properly control the PWM fans the fans have to be 4-pin, not the 3-pin (no sense pin) that are included.
It all works now after having replaced the fans altogether.


Makre sure you are running ipmitool as root. I get the same error as you get if I try to run it as a regular user.

1 Like