Just received HL15 and Kernel Modules failed to load

I just received the HL15 (fully burned in), powered it up, got into Houston and there was an error with the Kernel Module Service. Did some digging around and can’t really find anything that works. Didn’t see anything in the forums either. Wondering if you can help. This is a brand new system with no config on it yet.

HI @cDMB41, Can you try to update the system to the lastest versions of packages and kernel and then give the system a reboot and make sure it boots into the newest kernel available?

Updated. Still showing that it can’t load the kernel modules.

Ok. Getting a little closer. Running journalctl on that PID i get back the following:

[45drives@hl15 ~]$ journalctl _PID=702
– Logs begin at Thu 2024-02-08 08:55:49 AST, end at Thu 2024-02-08 09:50:19 AST. –
Feb 08 08:55:52 hl15 systemd-modules-load[702]: Module ‘msr’ is builtin
Feb 08 08:55:52 hl15 systemd-modules-load[702]: Failed to find module ‘zfs’

Ok. Here’s what I have got. Just in case someone else runs into this.
I ran the following

sudo dnf config-manager --enable zfs-testing
sudo dnf install kernel-devel zfs

This allowed the install to complete and added the required zfs to the kernel which started the service.

Hopefully that is correct and ok to do the above. I didn’t have much to lose since it’s a clean install with no data or anything on it yet.

Looks like going back to the latest kernel broke it again. Still working through this.

Ok. It looks like the issue is with Kernel 4.18.0-513.11.1.el8_9.x86_64. I can’t get it running on this kernel version. I have removed this kernel and everything seems to working fine now. Seems to be an issue with ZFS on this kernel version.

If anyone has any thoughts, please let me know.

HI @cDMB41, I believe this new kernel was just released and ZFS has not been updated to work with it yet

Any updates on this im having the same issue after updating.

Hi All,

Could you try running the following:

update-initramfs -u

If that does not work could you instead check the status of the failed service? it should give a PID which we can then investigate to see what it is having an issue with.

If the status does not have a PID try restarting the service and after a restart, it should give a new PID which we can use journbalctl to see what the issue is

$ systemctl status systemd-modules-load  
systemd-modules-load.service - Load Kernel Modules      
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)     
   Active: failed (Result: exit-code) since So 2013-08-25 11:48:13 CEST; 32s ago  
     Docs: man:systemd-modules-load.service(8).  
  Process: 15630 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
$ journalctl _PID=15630
-- Logs begin at Sa 2013-05-25 10:31:12 CEST, end at So 2013-08-25 11:51:17 CEST. --
Aug 25 11:48:13 mypc systemd-modules-load[15630]: Failed to find module 'blacklist usblp'
Aug 25 11:48:13 mypc systemd-modules-load[15630]: Failed to find module 'install usblp /bin/false'

These are just examples but could you provide the output of the journalctl of the failed PID?

I rolled back to the previous kernel. I was able to remove ZFS as that was my faulting service. I removed ZFS and reinstalled v2.3. Once that was done, I updated to the latest kernel from the web interface (not command line) and it upgraded successfully.

Want to add, my system was a clean, install with no data on it

1 Like

Sorry for not responding. I’m not able at the moment to try anything. I’m currently sitting in the hospital. I’m a one man show at the office so I have no one to help me with this. I can say this happened right after I did an update. I ran sudo dnf update. Right after I had the issue and posted on here I was not feeling well and went into the hospital. I cant pull any logs at the moment.

Wishing you a speedy recovery, @nolashadow

So I got home this morning. Sat down for a min and logged into the hl15. Seems like it fixed itself. There must have been an update while I was away. Ran an update again and everything is updated and everything seems to be working.

1 Like