HL15 Full Build - Options missing in Ubuntu 20.04

I manually re-installed Ubuntu 20.04 LTS after non-stop issues with the pre-install of Rocky 8. As I’m more familiar with Debian based distro’s and apt, I figured this would give me the most confidence moving forward.

I’m happy to say that the Software Updates tab is present under Ubuntu 20.04, which was not the case with the Rocky 8 pre-install. I’m also not getting errors in apt update or apt upgrade.

Large warning for anyone trying…
I was unable to re-import my ZFS pool in Ubuntu from Rocky through Houston UI. I’m unsure what the reasoning for this was, and even tried “force import” which failed. It said the pool was created on another system.

I’m also now unable to open the 45Drives Disks tab, and instead am greeted with a message stating " This module is designed to work with 45Drives servers". Which is a bit off-putting to say the least, as my primary driving factor for purchase was to use the 45Drives utilities as they come.

1 Like

I’m sure one of their tech will comment and help. It would make sense to at least allow the 45Drives Disks tab even reinstalling a new Distro since you are in fact on a 45Drives server!

1 Like

That’s my thought. I ran the benchmark through the UI off the initial install as a “baseline”. Installing Ubuntu and setting the Performance Profile to the same one used in Rocky, I’m about half the throughput now.

I ran Clonezilla as the first thing I did once receiving the box before any tinkering, so I can always swap back. But I am going to try a quick clean install of Rocky 8 and see how that goes.

Hi @orix
When you tried to re-import your ZFS pool, it sounds like you were in Rocky and using the Houston tool. You might want confirmation from @Hutch-45Drives , but I believe you might actually have to run the command from the command line.

I haven’t used Houston yet, can you run a zpool status command?

Yeah, Houston has most ZFS features, it’s really nice! The reimport failed, on CLI as well. Said it was used by another system previously and then had errors regarding the pool name not having been set by the Cockpit ZFS manager (which is what Houston is).

Hi @orix , are you willing to try the command line? (this command with the -n option will test the recovery option without actually doing it). It’s not 100% recovery even if it works. It will discard some of the last transactions. These options are BSD based, but I hope were applied the same way in Linux.

if so, run :

zpool import -f -FXn Pool-1 (where “pool-1” is actual name of your pool)

-f :Forces import,|even if the pool appears to be potentially active.

-F : Recovery mode for a non-importable pool. Attempt to
return the pool to an importable state by discarding
the last few transactions. Not all damaged pools can
be recovered by using this option. If successful, the
data from the discarded transactions is irretrievably
lost. This option is ignored if the pool is importable
or already imported.

-X :Used with the -F recovery option. Determines whether
extreme measures to find a valid txg should take place.
This allows the pool to be rolled back to a txg which
is no longer guaranteed to be consistent. Pools im-
ported at an inconsistent txg may contain uncorrectable
checksum errors. For more details about pool recovery
mode, see the -F option, above. WARNING: This option
can be extremely hazardous to the health of your pool
and should only be used as a last resort.

-n :Used with the -F recovery option. Determines whether a
non-importable pool can be made importable again, but
does not actually perform the pool recovery.
For more
details about pool recovery mode, see the -F option,

I tried a fresh Rocky install before bed last night. Happy to say that that is going a bit better, but still not great. This time, I was able to re-import the pool but just as you said did have to do it via CLI with zpool import -f ironwolf-pool. I’ll have to do some digging today to see if I can see what commands are passed when importing via Cockpit/Houston. Trying with the GUI fails, but CLI succeeds, which you would think choosing force in either place would be the same.

Oh, and disk speeds returned to what the pre-installed image had when I did a clean Rocky install. Wondering if there’s something up with the Ubuntu ZFS packages.

Still cannot see 45Drives Disks tab. But I think I’m close to narrowing it down. It looks like I’m missing a json file.
/opt/45drives/tools/server_identifier: Error loading data from /etc/45drives/server_info/server_info.json

I created the one referenced with touch /etc/45drives/server_info/server_info.json then ran dmap again, this time it asked if it could overwrite the file, but still failed the scan after:

Error Message: Expecting value: line 1 column 1 (char 0) /opt/45drives/tools/server_identifier: Would you like to overwrite existing file with new scan results? (y/n):y Traceback (most recent call last): File "/opt/45drives/tools/server_identifier", line 960, in <module> main() File "/opt/45drives/tools/server_identifier", line 940, in main server["Alias Style"] = g_product_lut[server["Model"]][g_product_lut_idx["ALIAS_STYLE"]] KeyError: 'HomeLab-HL15' dmap failed to get server information

Strangely, still seeing quite a few SMB errors, and have not tried getting Realmd to work. Unfortunately, the implementation chosen here is winbind rather than sssd. I believe winbind is not used as much, and I don’t know it nearly as well as I know sssd.

SELinux errors include:
SELinux is preventing /usr/sbin/smbd from write access on the file smbd.pid.
SELinux is preventing /usr/bin/smbcontrol from using the dac_read_search capability.
SELinux is preventing /usr/bin/smbcontrol from sendto access on the unix_dgram_socket /var/lib/samba/private/msg.sock/6716.

I tried a few of the inline suggested commands, which feels like a sliding puzzle as it just causes another to pop up. I’m going to give some of their Ansible tasks a try later.

1 Like

Hi @orix, The reason you could not import the pool on Ubuntu 20.04 was that the ZFS pool was made in Rocky8 which has a newer version of ZFS.

you can not create a ZFS pool on a new version and then import it onto an older version, you would need to remake your pool for it to work on Ubuntu

As for the new Rocky install, we have a preconfig script you can run which should install all the packages you need again located here. https://scripts.45drives.com/rocky-preconfig.sh

After the script is run you will need to enable the testing repo as the tools required for the HL15 are not in the stable repo yet.

Once the testing repo is enabled could you try to update and then reboot? once that is done then try to run dmap again to alias the system

We use Winbind for our Domain Join so that SMB shares can use it to authenticate for permission auth, if you are not using it for that you can use anything you prefer to join the Domain with using the CLI


Hi Hutch,

Thanks for the clarification. My thoughts were around ZFS being different packages between Ubuntu/Rocky. which makes sense!

I made another post where I outlined some of the troubles I was having with Rocky after a clean install. If the testing repo is the one to use, I’ll happily point there, as I stumbled on it looking for different packages and commands missing. I noted some of the things I found here in a separate post as I realized it would be easier and cleaner for discussion purposes.

In that post I was able to get dalias working after manually targeting the target repo and pulling the newer tools and iscsi package. This let me re-run the disk mapping, but still says that the system itself is unrecognized. I’ll give the full testing packages a go, and then reply in that post!