Ethernet Connected, Multicast UP, got an IP but I can't ping anything?

Hi all,
I’ve been playing around with my server and my network stopped working and I can’t figure out why.

  • IP address manually set to a matching IP on my router
  • Server connects via a PoE switch to router
  • Disabled IPv6 just in case
> ip -c a

> nmcli device

So it should be connected right? But dnf update, traceroute, and ping all timeout unable to connect as does my web browser.
I also tried disabling the firewall under the copilot settings http://localhost:9090 with no success.


I’m really at a loss here, other things are connected via the same switch and work fine and I can access the server via IPMI (reason I used screencaps), so I can’t figure out why it isn’t working, where it has worked before and sometimes flickers into life and dies off…

Any suggestions on how to diagnose this?

If this is Rocky Linux you may want to check firewalld and selinux.

You could temporary turn the service off to see what is happens? If you get success, then you may need to adjust the firewall rules.

1 Like

virbr0 has no carrier on it so although you have an IP there is no data connection for that interface.

I would suggest configuring eno1 instead of virbi0. that interface is for VMs if you are using that in Houston

Thanks Hutch, I currently have eno1 set as activated. Disabling virbr0 using nmtui just seems to cause another one to spawn. How can I tell the machine to not use virbr0? I don’t recall ever setting that to default or even setting it up at all.

I connected via eno2 from the same cable and with similar settings (IP set 1 number off) and it worked! So I’m at a loss why eno1 isn’t working even though it shows an internet connection.

If you want to remove the virbr0 you will need to remove “cockpit-machines” and then you can remove the interface.

This package creates that interface for VMs to have a virtual bridge to your network.

Once that’s removed I would suggest reconfiguring eno1 again.