Cockpit login w/ root

I am running cockpit (Houston ui) on the base os with promox. At first I wasn’t experiencing any issues. I was able to login to the cockpit-ws using root login. After a day or 2 the root login stopped working. These are the steps i’ve taken so far.

  • Restarted Cockpit services
  • Restarted the server
  • Created a different linux user
  • Changed the password of root
  • Complete uninstall/re-install of cockpit and supporting packages.

The only error I can track down is…

proxmox cockpit-session[233593]: pam_env(cockpit:session): deprecated reading of user environment enabled
May 07 21:03:15 proxmox cockpit-ws[233600]: Traceback (most recent call last):
May 07 21:03:15 proxmox cockpit-ws[233600]: File “/usr/bin/cockpit-bridge”, line 5, in
May 07 21:03:15 proxmox cockpit-ws[233600]: from cockpit.bridge import main
May 07 21:03:15 proxmox cockpit-ws[233600]: ModuleNotFoundError: No module named ‘cockpit’
May 07 21:03:15 proxmox cockpit-session[233593]: pam_unix(cockpit:session): session closed for user root
May 07 21:03:15 proxmox systemd[1]: session-62.scope: Deactivated successfully.

Is there an issue with Cockpit’s path? I am not sure where to look to resolve this issue.

For clarity, the new Linux user also doesn’t work and has the same error?

Yes, that is correct.

Got it - which version of Proxmox are you running? I’m running the latest version 8.2. When I have a moment this afternoon, I’ll give it a try and see if I observe the same behavior.

Have you tried yet to install and login to cockpit without the extra HoustonUI packages from 45drives? I don’t see anything in the logs to indicate that’s the problem but seems like a logical troubleshooting step by removing a variable.

Version 8.2.2

Uninstalling the 45drives modules did not do the trick, so I uninstalled cockpit and all dependencies as well as the 45drives repo and did a fresh install of cockpit following their installatation guide. This ended up fixing the login issue. I can login from root and the other user I created. I re-added the 45drives repo and re-installed the houston modules as well as the 45drives tools packages. Everything is working well, but the 45drives “tools” modules are not showing up as they were originally before I reinstalled everything. … I will do additional digging on this.

I am however getting an error when trying to do “apt upgrade”
The following packages have unmet dependencies:
pve-firmware : Conflicts: firmware-linux-free but 20200122-1 is to be installed
E: Broken packages.

This is keeping me from updating these packages.

grub-common/stable-backports 2.12-1~bpo12+1 amd64 [upgradable from: 2.06-13+pmx2]
grub-efi-amd64-bin/stable-backports 2.12-1~bpo12+1 amd64 [upgradable from: 2.06-13+pmx2]
grub-efi-amd64-signed/stable-backports 1+2.12+1~bpo12+1 amd64 [upgradable from: 1+2.06+13+pmx2]
grub-efi-amd64/stable-backports 2.12-1~bpo12+1 amd64 [upgradable from: 2.06-13+pmx2]
grub-pc-bin/stable-backports 2.12-1~bpo12+1 amd64 [upgradable from: 2.06-13+pmx2]
grub2-common/stable-backports 2.12-1~bpo12+1 amd64 [upgradable from: 2.06-13+pmx2]
linux-compiler-gcc-12-x86/stable-backports 6.5.10-1~bpo12+1 amd64 [upgradable from: 6.1.85-1]
linux-headers-amd64/stable-backports 6.6.13-1~bpo12+1 amd64 [upgradable from: 6.1.85-1]
linux-libc-dev/stable-backports 6.6.13-1~bpo12+1 amd64 [upgradable from: 6.1.85-1]
smartmontools/stable-backports 7.4-2~bpo12+1 amd64 [upgradable from: 7.3-pve1]

I guess it’s a classic one step forward, two steps sideways situation. :no_mouth:

Glad to hear that cockpit is going again! I don’t have any issues on my proxmox+cockpit setup running 8.2.2. I guess something just got out of line and now it’s back in place.

As for the unmet dependency/conflict with firmware-linux-free, I don’t think you want to install that. The package isn’t on my proxmox install and installing it will remove the proxmox kernel and other pve packages. Maybe try apt-cache depends ‘firmware-linux-free’ to see what package is asking for that?

root@pve1:/etc/cockpit# apt install firmware-linux-free
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  proxmox-kernel-helper pve-kernel-5.11.22-7-pve pve-kernel-5.4.128-1-pve
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  proxmox-default-kernel proxmox-kernel-6.5 proxmox-kernel-6.8 proxmox-ve pve-firmware pve-kernel-5.11 pve-kernel-5.4
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 7 to remove and 0 not upgraded.

apt --fix-broken install and dpkg --configure -a are some of my other go to commands when apt or debian packages go awry.