Backplane not Detected

I have a 45Homelab case and backplanes only. I rebooted and boom no hard drives detected. I unplugged my LSI 9400-16i SATA/SAS HBA Controller card and plugged it back in and the sytems reads the card but no hard drives. I uplugged the cables and installed them still nothing. I then Plugged in the hard drives thru the motherboard and the drives popup without a issues. I think the board is dead. Ive been at this for a hour and nothing is being read from the board

Do the drives get power and spin? If you think you have an RMA issue probably quickest just to contact support directly.

Not sure you 100% ruled out the HBA. It could still power up and be detected by the OS but have bus circuitry that died. I’m not sure if it is more unlikely that none of the ports/channels on the backplane would work, or none on the HBA would work. The HBAs get hot and have a lot more logic circuitry and chips than the backplane. It might be good if you had an old HBA of some sort (cheap 92xx-8i or something) lying around to swap in, just to test that also doesn’t work.

Nothing is detected in the BIOS. However if i plug in the drive directly to the motherboard it spins up and is working without a issue

unfortunately i don’t have another card. I just ordered another one from amazon see if that’s the problem

I wasn’t suggesting you buy something, just in a homelab there’s usually old/extra stuff around. An alternative would be a reverse breakout cable from the SATA port((s) on the mobo to a SFF-8463 conneector on the backplane, since you know the mobo SATA ports work;

You need to be sure it’s a reverse cable though, as most of the ones on Amazon, and more common, are forward breakout.

Oh i see use this cable and connect them directly to the hard drives and see if thats the issue?

Hi @zerolimit,

  1. were the drives ever detected? (it sounds like they were)
  2. what power supply are you using?
  3. when you plug the drives into the motherboard directly, how are you powering the drives?
1 Like

I was trying to connect the backplane to something other than the 9400-16i, just as a reality check to help confirm the backplane as the issue, that could be by using a different HBA or the SATA ports on your motherboard. It’s still not clear if the drives, when in the backplane, are getting power. The power comes from the molex connectors on the side of the case, not the data cables and the HBA. Maybe a power cable got knocked loose or some other power supply issue.

1 Like
  1. All drives detected (Unraid now wont boot because 15 drives are missing)
  2. Corsair (i think)
  3. When I plugin the drive directly to the mother board they load up. I tried 3 drives

ahh I see, I ordered another card since I needed one for another Storinator I am getting today so either way I will try the new card when it comes in Friday

I appear to be going at this like @DigitalGarden is. (trying to determine if it is a power related issue).

I’m guessing your motherboard doesn’t support too many drives, like most of us. Testing 3 drives at a time will tell you if the drives are working. How are they being powered when testing by plugging onto the motherboard directly? by individual 15-pin power connectors?

You could try using only 1 group of cables to the HBA or only have half your drives plugged in. This would test power delivery for a subset of drives at a time. If the drives are recognized this way, it would point towards a power delivery problem. (like @DigitalGarden was trying to see if the drives are spinning.)

Do you have any other add-on cards (graphics, network, etc)?

Just so I’m clear, where are you determining this? In the UEFI/BIOS? From the OS boot messages? From within Unraid?

I’m not familiar with Unraid, but is it possible that the disks, hba and backplane are all ok and what got messed up is the Unraid information about the disk layout? Although maybe in that case Unraid should show some sort of “disks available to be added to the pool” screen.

It sounds like you did a controlled shutdown and reboot, not that there was an unexpected power outage, but I’ve had a couple times where I’ve had to re-import a ZFS pool after a reboot. All the data was fine, but somehow the OS lost track of the pool metadata.

Just another thought.

Well, that’ll make it trivial to determine the bad component. Another HL15, or a different enterprise model?

not a HL15 its a BackBlaze 2.0 Pod

@zerolimit If you believe this is a hardware issue with one of the complaints you received from us please reach out to and someone will be able to assist you with troubleshooting and replacing the bad part