# HL15 initial start (preinstalled system)

**URL:** https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753
**Category:** Software & Applications
**Created:** [November 27, 2023, 10:09pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753 "2023-11-27T22:09:17Z")
**Posts on this page:** 20
**Page:** 2

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 4:39pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/21 "2023-11-30T16:39:05Z")

</div>

ZFS Cockpit now matches.

ZFS lines in smb.conf removed. and SAMBA restarted.

I only added the shares, nothing was changed:

 ![image](https://forum.45homelab.com/uploads/default/original/1X/eecb3d5db52d0e0bdb0030ab6279e39c1edfd40f.png)

# netconf list

```auto
-bash: netconf: command not found

```

# net conf list

```auto
Unknown parameter encountered: "includes"
Unknown parameter encountered: "includes"
[global]
	security = user
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	load printers = yes
	cups options = raw
	workgroup = SAMBA
	include = /etc/samba/usershares.conf

[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @printadmin root
	force group = @printadmin
	create mask = 0664
	directory mask = 0775

[Multimedia]
	path = /Main/Multimedia
	guest ok = no
	comment = 
	read only = no
	browseable = yes
	valid users = "45drives"

[Backups]
	path = /Main/Backups
	guest ok = no
	comment = 
	read only = no
	browseable = yes
	valid users = "%D%w%S" "%S" "45drives"

```

Error is the same. Rebooting after all the changes didn’t help either.

---

<div class="post-metadata">

### Author: ![Hutch-45Drives](https://forum.45homelab.com/user_avatar/forum.45homelab.com/hutch-45drives/32/64_2.png) [@Hutch-45Drives](https://forum.45homelab.com/u/Hutch-45Drives)
#### Post date: [November 30, 2023, 5:50pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/22 "2023-11-30T17:50:09Z")

</div>

In the advanced option of the global section can you remove the line `include = /etc/samba/usershares.conf` and then restart SMB?

We need to remove that warning on testparm before SMB is going to work for us I believe.

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 5:59pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/23 "2023-11-30T17:59:28Z")

</div>

I tried that and get the following error:

> Failed to apply global settings
> 
> net: Unknown parameter encountered: “includes”  
> Error: given parameter ‘include’ is not set. (255)

and the values remain unchanged.

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 6:03pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/24 "2023-11-30T18:03:36Z")

</div>

I removed it wit `samba-regedit`

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 6:06pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/25 "2023-11-30T18:06:18Z")

</div>

```auto
systemctl restart smb.service 

```

Still broken.

This is now clean `net conf list`

```auto
[global]
	security = user
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	load printers = yes
	cups options = raw
	workgroup = SAMBA

[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @printadmin root
	force group = @printadmin
	create mask = 0664
	directory mask = 0775

[Multimedia]
	path = /Main/Multimedia
	guest ok = no
	comment = 
	read only = no
	browseable = yes
	valid users = "45drives"

[Backups]
	path = /Main/Backups
	guest ok = no
	comment = 
	read only = no
	browseable = yes
	valid users = "%D%w%S" "%S" "45drives"

```

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 6:11pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/26 "2023-11-30T18:11:29Z")

</div>

The SFP+ ports are LAG bonded with 802.3ad, but I don’t that it should matter.

 ![image](https://forum.45homelab.com/uploads/default/original/1X/7377349fad077994dc6975d25505299669b68bb0.png)

---

<div class="post-metadata">

### Author: ![Hutch-45Drives](https://forum.45homelab.com/user_avatar/forum.45homelab.com/hutch-45drives/32/64_2.png) [@Hutch-45Drives](https://forum.45homelab.com/u/Hutch-45Drives)
#### Post date: [November 30, 2023, 6:31pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/27 "2023-11-30T18:31:28Z")

</div>

Now that the include lines are gone are you still getting the same thing in Samba? if so I would suggest setting the log level to 4 and tail the SMB log while you try to connect to see if that indicates the issue

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 6:37pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/28 "2023-11-30T18:37:10Z")

</div>

Error persists, log:

```auto
[2023/11/30 19:35:39.809853, 0] ../../source3/smbd/smb2_service.c:749(make_connection_snum)
  make_connection_snum: canonicalize_connect_path failed for service Backups, path /Main/Backups
[2023/11/30 19:35:39.809918, 3] ../../source3/smbd/smb2_server.c:3964(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_BAD_NETWORK_NAME] || at ../../source3/smbd/smb2_tcon.c:151

```

find /Main/ -ls

```auto
       34 1 drwxr-xr-x 4 root root 4 Nov 28 07:49 /Main/
       34 1 drwxr-xr-x 2 root root 2 Nov 28 07:49 /Main/Backups
       34 1 drwxrwxr-x 2 45drives 45drives 2 Nov 30 03:42 /Main/Multimedia

```

```auto
root 11468 0.0 0.0 419532 25168 ? Ss 19:02 0:00 /usr/sbin/smbd --foreground --no-process-group
root 11473 0.0 0.0 410248 11188 ? S 19:02 0:00 \_ /usr/sbin/smbd --foreground --no-process-group
root 11474 0.0 0.0 410248 4360 ? S 19:02 0:00 \_ /usr/sbin/smbd --foreground --no-process-group
root 11500 0.0 0.0 426228 19992 ? S 19:04 0:00 \_ /usr/sbin/smbd --foreground --no-process-group

```

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 6:45pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/29 "2023-11-30T18:45:12Z")

</div>

Maybe the share defaults aren’t right?

 ![image](https://forum.45homelab.com/uploads/default/original/1X/51025a197f8c55729b21adb1a3ecf1c3f439d840.png)

---

<div class="post-metadata">

### Author: ![Hutch-45Drives](https://forum.45homelab.com/user_avatar/forum.45homelab.com/hutch-45drives/32/64_2.png) [@Hutch-45Drives](https://forum.45homelab.com/u/Hutch-45Drives)
#### Post date: [November 30, 2023, 6:55pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/30 "2023-11-30T18:55:42Z")

</div>

I see whats going on. Your tryting to use SMB2 to connect to the server.

Add

```auto
[Global]
min protocol = SMB2

```

Then restart SMB and try again

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 7:05pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/31 "2023-11-30T19:05:23Z")

</div>

Same result:

```auto
[2023/11/30 20:02:42.482042, 0] ../../source3/smbd/smb2_service.c:749(make_connection_snum)
  make_connection_snum: canonicalize_connect_path failed for service Backups, path /Main/Backups
[2023/11/30 20:02:42.482076, 3] ../../source3/smbd/smb2_server.c:3964(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_BAD_NETWORK_NAME] || at ../../source3/smbd/smb2_tcon.c:151

```

net conf list

```auto
[global]
	security = user
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	load printers = yes
	cups options = raw
	workgroup = SAMBA
	log level = 4
	server min protocol = SMB2

[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @printadmin root
	force group = @printadmin
	create mask = 0664
	directory mask = 0775

[Multimedia]
	path = /Main/Multimedia
	guest ok = no
	comment = 
	read only = no
	browseable = yes
	valid users = "45drives"

[Backups]
	path = /Main/Backups
	guest ok = no
	comment = 
	read only = no
	browseable = yes
	valid users = "%D%w%S" "%S" "45drives"

```

---

<div class="post-metadata">

### Author: ![Hutch-45Drives](https://forum.45homelab.com/user_avatar/forum.45homelab.com/hutch-45drives/32/64_2.png) [@Hutch-45Drives](https://forum.45homelab.com/u/Hutch-45Drives)
#### Post date: [November 30, 2023, 7:41pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/32 "2023-11-30T19:41:08Z")

</div>

Can you try to remove the capitals in the share and make a new path without capitals? Linux is case sensitive whereas Windows is not as much so that could be causing it.

The error also says the following from the log:

> [@Bill](#):
>
> `NT_STATUS_BAD_NETWORK_NAME`

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 7:46pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/33 "2023-11-30T19:46:26Z")

</div>

From linux:

```auto
[2023/11/30 20:44:26.987738, 0] ../../source3/smbd/smb2_service.c:749(make_connection_snum)
  make_connection_snum: canonicalize_connect_path failed for service backups, path /Main/Backups
[2023/11/30 20:44:26.987879, 3] ../../source3/smbd/smb2_server.c:3964(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_BAD_NETWORK_NAME] || at ../../source3/smbd/smb2_tcon.c:151
[2023/11/30 20:44:26.988121, 3] ../../source3/smbd/smb2_server.c:3964(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_NETWORK_NAME_DELETED] || at ../../source3/smbd/smb2_server.c:3253

```

From Windows 10:

```auto
[2023/11/30 20:46:06.837423, 0] ../../source3/smbd/smb2_service.c:749(make_connection_snum)
  make_connection_snum: canonicalize_connect_path failed for service backups, path /Main/Backups
[2023/11/30 20:46:06.837455, 3] ../../source3/smbd/smb2_server.c:3964(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_BAD_NETWORK_NAME] || at ../../source3/smbd/smb2_tcon.c:151

```

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 7:56pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/34 "2023-11-30T19:56:50Z")

</div>

Is it a permissions error?

```auto
# find /Main/ -ls
       34 1 drwxr-xr-x 4 root root 4 Nov 28 07:49 /Main/
       34 1 drwxr-xr-x 2 root root 2 Nov 28 07:49 /Main/Backups
       34 1 drwxrwxr-x 2 45drives 45drives 2 Nov 30 03:42 /Main/Multimedia

```

Switches in “File Sharing”  
 ![image](https://forum.45homelab.com/uploads/default/original/1X/f02cb84328a2615b4510a3c6872a6985b1c87949.png)

root:root on /Main/Backups ?

This doesn’t seem to do anything:  
 ![image](https://forum.45homelab.com/uploads/default/original/1X/81cb436f7bbfaaae09dbbde49aa50f7559876018.png)

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 8:00pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/35 "2023-11-30T20:00:17Z")

</div>

Linux on the client sees everything as far as I can tell:  
$ smbclient -L //hl15 --user=45drives --workgroup=SAMBA --password=\*\*\*\*\*\*\*\*

```auto
Can't load /etc/samba/smb.conf - run testparm to debug it

	Sharename Type Comment
	--------- ---- -------
	IPC$ IPC IPC Service (Samba 4.18.6)
	print$ Disk Printer Drivers
	backups Disk      
	multimedia Disk      
	45drives Disk Home Directories
SMB1 disabled -- no workgroup available

```

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 8:11pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/36 "2023-11-30T20:11:19Z")

</div>

Is HL15 not the SMB server name?

smbclient \\HL15\backups -I 192.168.76.102 --user=45drives --workgroup=SAMBA --password=\*\*\*\*\*\*\*\* -l

```auto
Can't load /etc/samba/smb.conf - run testparm to debug it
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

```

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [November 30, 2023, 8:15pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/37 "2023-11-30T20:15:10Z")

</div>

Still broken with

```auto
[global]
	security = user
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	load printers = yes
	cups options = raw
	workgroup = SAMBA
	log level = 4
	server min protocol = SMB2
	netbios name = HL15

```

---

<div class="post-metadata">

### Author: ![Hutch-45Drives](https://forum.45homelab.com/user_avatar/forum.45homelab.com/hutch-45drives/32/64_2.png) [@Hutch-45Drives](https://forum.45homelab.com/u/Hutch-45Drives)
#### Post date: [December 1, 2023, 1:02pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/38 "2023-12-01T13:02:43Z")

</div>

what is the hostname on the system?

I would suggest removing anything with capital from SMB and then trying.

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [December 1, 2023, 5:41pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/39 "2023-12-01T17:41:15Z")

</div>

Name is unchanged: hl15

Already renamed to “backups” “multimedia”

Home directory “45drives” fails the same way.

---

<div class="post-metadata">

### Author: ![Bill](https://forum.45homelab.com/user_avatar/forum.45homelab.com/bill/32/70_2.png) [@Bill](https://forum.45homelab.com/u/Bill)
#### Post date: [December 1, 2023, 6:32pm UTC](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753/40 "2023-12-01T18:32:13Z")

</div>

Correction, 45drives fails with:

```auto
[2023/12/01 19:30:55.737530, 3] ../../source3/smbd/smb2_server.c:3964(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_ACCESS_DENIED] || at ../../source3/smbd/smb2_create.c:340

```

[Previous page](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753.md?page=1)

[Next page](https://forum.45homelab.com/t/hl15-initial-start-preinstalled-system/753.md?page=3)
